Incident announced by Tieto Banktech

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted Jun 22, 2026 - 06:33 UTC

Identified

Message from Tieto Banktech:

Affected Areas: EMV 3D Secure Issuing, My Cards, Mobile Paymen, Personal Internet Banking, Corporate Internet Banking, Loan Process, eSignering, Self Service Solutions


Description:
We are currently experiencing issues where some customers are encountering instability with different SMS-related services, affecting My Cards, 3D Secure, Mobile Payment, Loan Processing, eSigning, and Self Service solutions (PIB, CIB).

Status:
The vendor has confirmed that the issue is caused by one of their subcontracts.
We will update with more information as soon as it becomes available, taskforce is ongoing.

Started: 19-06-2026 12:10 CEST

Next notification will be sent within 1 hour.
Posted Jun 19, 2026 - 13:02 UTC
This incident affected: Live (API, Checkout).