Incident announced by BankData

Incident Report for Neonomics

Resolved

Message from the bank:

The outage was resolved at 12:41 CEST, and traffic has normalized.
Posted Mar 12, 2025 - 12:02 UTC

Identified

Message from BankData:

We are experiencing outage across Bankdata, including the PSD2 APIs.
Posted Mar 12, 2025 - 11:20 UTC
This incident affected: Live (API, Checkout).