Experiencing degraded service from Handelsenbanken SE

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted Jul 06, 2025 - 21:15 UTC

Investigating

Bank is returning 500 internal server error for some of the consent requests.

We will post an update once we have additional information.
Posted Jun 25, 2025 - 12:25 UTC
This incident affected: Live (API, Checkout).