Investigating issues for requests targeting Poppankki and Omasp banks in Finland

Incident Report for Neonomics

Investigating

Our Engineering team is investigating issues with Poppankki and Omasp banks in Finland.

Customers could be getting Unauthorized Payment in certain scenarios. We are investigating if the issue originates from the Neonomics side or the bank's side, as this is affecting callbacks to our customers.

The issue is not affecting most of the requests in for these banks, but a small percentage of them.

We will post an update once we have additional information.
Posted Mar 13, 2025 - 11:29 UTC
This incident affects: Live (API, Checkout).