Incident with OmaSp, Säästöpankki, Samlink and POP Pankki

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted Aug 24, 2025 - 10:56 UTC

Monitoring

Maintenance is ongoing on the banks side from 5:00 AM to 1:00 PM on August 24, 2025
Posted Aug 24, 2025 - 08:09 UTC

Investigating

We have identified an issue with these banks in the Finnish market and have escalated it to the banks.

We will update when we have more information.
Posted Aug 24, 2025 - 08:06 UTC
This incident affected: Live (API, Checkout).