Incident announced by Nordea

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted May 11, 2026 - 10:03 UTC

Identified

Message from Nordea:

Please be informed that the Open Banking Account Information Service (AIS) and Payment Information Service (PIS) in all countries are facing technical problems.

We are sorry for the inconvenience.

Regards,

Nordea Open Banking Technical Assistance
Posted May 11, 2026 - 08:16 UTC
This incident affected: Live (API, Checkout).