Incident announced by Nordea Finland

Incident Report for Neonomics

Update

We are continuing to work on a fix for this issue.
Posted Apr 07, 2026 - 09:10 UTC

Identified

Message from Nordea Finland:

Please be informed that the Open Banking Account Information Service (AIS) in Finland is facing technical problems.
Posted Apr 07, 2026 - 09:10 UTC
This incident affects: Live (API, Checkout).