Danske Bank – Unable to Fetch Payment Details for Payments Created Before February 19th - 16:20 UTC

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 09:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2026 - 19:59 UTC

Investigating

Our Engineering team is investigating an issue when fetching payment details for past payments in Danske Bank.

Payments created before Feb 19, 17:20 (16:20 UTC) are failing when fetched.
This issue does not affect any payments created after that time.

We are working to deploy a fix, but are investigating other mitigation avenues to quickly resolve customer impact.

We will post an update once we have additional information.
Posted Feb 19, 2026 - 17:25 UTC
This incident affected: Live (API, Checkout).