Incident announced by Nordea

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted Apr 26, 2026 - 18:45 UTC

Identified

Nordea has announced an incident in the nordics. Be aware that the way Nordea is failing is causing that customers receive 520 status code errors. This would normally mean the problem comes from Neonomics, but it is not the case. If there's retry logic on the customer's side to retry, it will keep receiving 520 until the bank stabilizes on their side.

Message from Nordea:

Please be informed that the Open Banking Account Information Service (AIS) and Payments Initiation Service (PIS) in Denmark, Finland, Norway and Sweden is facing technical problems.
Posted Apr 26, 2026 - 06:38 UTC
This incident affected: Live (API, Checkout).