Incident announced by Nordea Open Banking: PIS API SE issues

Incident Report for Neonomics

Resolved

Please be informed that technical problems with the Payment Information Service (PIS) in Sweden are solved.
Posted 8 days ago. Mar 26, 2025 - 08:03 UTC

Investigating

Information provided by Nordea:
Please be informed that the Payment Information Service (PIS) in Sweden is facing technical problems.
Some customers may be affected and face issues while using our APIs.
Posted 8 days ago. Mar 26, 2025 - 08:02 UTC
This incident affected: Live (API, Checkout).