We are experiencing instability with DNB Bank (Norway)

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted Aug 08, 2026 - 15:50 UTC

Investigating

Our Engineering team is investigating an issue with DNB

We will post an update once we have additional information.
Posted Aug 07, 2026 - 08:41 UTC
This incident affected: Live (API, Checkout).