We are experiencing issues with multiple banks resulting in either timed out requests or 520 status codes

Incident Report for Neonomics

Resolved

It was identified that:
* The problem around OP in Finland was a problem on the bank's side which was fixed by OP Finland around 6:40am UTC
* The problem around Danske was an internal component retrying failed requests to Danske. These retries went above our overall timeout limit.

We will investigate how to fail faster and make less re-tries to not cause this kind of time outs for customers
Posted Mar 31, 2026 - 09:30 UTC

Investigating

Our Engineering team is investigating an issue with multiple banks where we are timing out or sending 520 status codes to our customers.

So far, this has been detected with Finish banks OP and Danske.

We are working to deploy a fix, but are investigating other mitigation avenues to quickly resolve customer impact.

We will post an update once we have additional information.
Posted Mar 31, 2026 - 08:51 UTC
This incident affected: Live (API, Checkout).