Incident announced by Nordea
Incident Report for Neonomics
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 14:29 UTC
Identified
Message from Nordea:

PSD2 APIs might experience sporadic disturbances.
This impacts all our customer channels.
Posted Sep 19, 2024 - 12:26 UTC
This incident affected: Live (API, Checkout).