Incident announced by Nordea
Incident Report for Neonomics
Resolved
This incident has been resolved.
Posted May 30, 2024 - 11:13 UTC
Identified
Message from Nordea:

Please be informed that the Open Banking Account Information Service (AIS) in Finland and Denmark are facing technical problems. Also Business Payments Service is facing technical problems.
Posted May 30, 2024 - 08:31 UTC
This incident affected: Live (API, Checkout).