NORDEA: Ongoing incident with Nordea NO

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 12:41 UTC

Investigating

We are experiencing a high failure rate for invoice payments for Nordea NO.
We are currently investigating the issue and will feedback on the resolution.
Posted Mar 19, 2025 - 09:58 UTC
This incident affected: Live (API, Checkout).