Incident announced by Nordea

Incident Report for Neonomics

Resolved

Message from Nordea:

Please be informed that technical problems in the Open Banking Account Information Service (AIS) and Payment Information Service (PIS) in all countries are solved.
Posted May 05, 2026 - 07:00 UTC

Identified

Message from Nordea:

Please be informed that the Open Banking Account Information Service (AIS) and Payment Information Service (PIS) in all countries are facing technical problems.
Posted May 04, 2026 - 17:25 UTC
This incident affected: Live (API, Checkout).