Transactions missing from Merchant Portal

Incident Report for Neonomics

Resolved

Missing data is now available on Merchant Portal.
This incident has been resolved.
Posted Jun 04, 2025 - 11:58 UTC

Identified

The issue has been identified and a fix has been deployed.
All newer transactions will now be available in the Merchant Portal.

We are working on restoring the data lost between 28 May 2025 to 2 Jun 2025.
We will post an update once this is done.
Posted Jun 02, 2025 - 14:28 UTC

Investigating

Our Engineering team is investigating an issue with Merchant Portal.

Transactions are missing in the Merchant Portal since 28 May 2025.
Publishing of events is not working as expected.
The actual payments by customers are not impacted.

We are working to deploy a fix, but are investigating other mitigation avenues to quickly resolve customer impact.

We will post an update once we have additional information.
Posted Jun 02, 2025 - 08:30 UTC