OP Group: Ongoing Incident
Incident Report for Neonomics
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 14:56 UTC
Investigating
There is an ongoing incident with OP bank affecting AIS and PIS.
We are currently investigating this.
Posted Jan 14, 2025 - 08:56 UTC
This incident affected: Live (API, Checkout).