Incident announced by OP Finland

Incident Report for Neonomics

Resolved

Message from the bank: Our specialists have managed to implement a fix much faster than anticipated. We are pleased to inform you that our PSD2 APIs are fully operational.

--------
Neonomics will continue monitoring the situation
Posted Aug 20, 2025 - 14:06 UTC

Identified

Message from OP:

We have noticed a service disruption affecting OP's PSD2 APIS. OP PSD2 API users may experience issues. Our specialists are investigating the problem. We apologise for any inconvenience caused by the disruption.
Posted Aug 20, 2025 - 12:35 UTC
This incident affected: Live (API, Checkout).