Incident announced by Nordea Finland
Incident Report for Neonomics
Resolved
The bank has said the issue is resolved
Posted Sep 11, 2024 - 13:11 UTC
Identified
Message from Nordea Finland:

Please be informed that the Open Banking AIS FI and PIS FI services are facing technical problems.

Please contact us by raising a ticket in case you have any questions or feedback.
Posted Sep 11, 2024 - 12:55 UTC
This incident affected: Live (API, Checkout).