Incident announced by Nordea

Incident Report for Neonomics

Resolved

Please be informed that the technical problems in the Open Banking Payment Information Service (PIS) in Finland, Denmark and Norway are solved.
Posted May 21, 2026 - 21:52 UTC

Identified

Message from Nordea:

Please be informed that the Open Banking Payment Information Service (PIS) in Finland, Denmark and Norway is facing technical problems.
Posted May 21, 2026 - 12:12 UTC
This incident affected: Live (API, Checkout).