Incident announced by Nordea

Incident Report for Neonomics

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 10:47 UTC

Identified

Message from Nordea:

Please be informed that the Open Banking Account Information Service (AIS) and Payment Initiation Service (PIS) in Sweden, Norway, Finland and Denmark are facing technical problems.
Please contact us by raising a ticket in case you have any questions or feedback.
Posted Feb 27, 2026 - 08:40 UTC
This incident affected: Live (API, Checkout).