BEC banks are currently disabled due an incident.

Incident Report for Neonomics

Resolved

The incident has been resolved, and the banks are enabled.
Posted Apr 29, 2025 - 09:53 UTC

Investigating

Our Engineering team is investigating an issue with BEC bank integration. Currently account or payment functionality will not work with any BEC banks, and they are disabled temporarily from our platform

We are working to deploy a fix, but are investigating other mitigation avenues to quickly resolve customer impact.

We will post an update once we have additional information.
Posted Apr 26, 2025 - 10:22 UTC
This incident affected: Live (API, Checkout).