Bankdata: Ongoing Incident
Incident Report for Neonomics
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 08:03 UTC
Investigating
Bankdata banks are experiencing an ongoing incident affecting all payment routes.
We will update once we have feedback from the bank.
Posted Jan 15, 2025 - 06:40 UTC
This incident affected: Live (API, Checkout).