Incident announced by Nordea

Incident Report for Neonomics

Resolved

Please be informed that the Open Banking Payment Information Service (PIS) in Finland are solved.
Posted May 20, 2026 - 17:40 UTC

Identified

Message from Nordea:

Please be informed that the Open Banking Payment Information Service (PIS) in Finland is facing technical problems.
Posted May 20, 2026 - 16:54 UTC
This incident affected: Live (API, Checkout).